MK902 PIA VPN not working.

Forum to discuss the quad core MK902 Android PC

Moderators: KEgg, twjordo, tatubias

MK902 PIA VPN not working.

Postby cimzaki » Tue May 26, 2015 1:07 pm

Anybody who has got the Private Internet Access app (1.17) to Work?
On my MK902 (firmware MK902FW_150108) it ends up with "not connected" every time after running all the initial steps ok.
Tried with all types of settings UDP, TCP and all the different ports.
Same result on both my MK902.
OBS! I have a MK902II which is working flawlessly with the PIA app. :o

If You made it Work I wil be happy to know your settings.
Posts: 17
Joined: Sat Oct 04, 2014 4:01 pm

Re: MK902 PIA VPN not working.

Postby christom » Wed Jun 10, 2015 5:28 pm

I reckon my problem is similar to yours.
My friend with MK 902 II works a treat on VPN wiht freedome app for VPN.
I cannot get MK 902 to work. I need a username and password that it will accept otherwise it goes back to DISCONNECTED.
Man in China does not seem to be able to help me.
Posts: 2
Joined: Wed Jun 10, 2015 10:34 am

Return to Rikomagic MK902 Android PC Forum

Who is online

Users browsing this forum: No registered users and 3 guests